Prerequisites

Before getting started with the Xonai Accelerator on Amazon EMR, ensure you meet the following requirements:

The supported EMR versions for using the Xonai Accelerator are listed in the following table and with the corresponding JAR artifact name:

EMR release

Spark release

Processor

Xonai Accelerator JAR

6.10.1

3.3.1

Intel

xonai-spark-plugin-emr-6.10.1-x86_64.jar

Graviton

xonai-spark-plugin-emr-6.10.1-aarch64.jar

6.10.0

Intel

xonai-spark-plugin-emr-6.10.0-x86_64.jar

Graviton

xonai-spark-plugin-emr-6.10.0-aarch64.jar

6.9.1

3.3.0

Intel

xonai-spark-plugin-emr-6.9.1-x86_64.jar

Graviton

xonai-spark-plugin-emr-6.9.1-aarch64.jar

6.9.0

Intel

xonai-spark-plugin-emr-6.9.0-x86_64.jar

Graviton

xonai-spark-plugin-emr-6.9.0-aarch64.jar

6.8.0

Intel

xonai-spark-plugin-emr-6.8.0-x86_64.jar

Graviton

xonai-spark-plugin-emr-6.8.0-aarch64.jar

6.7.0

3.2.1

Intel

xonai-spark-plugin-emr-6.7.0-x86_64.jar

Graviton

xonai-spark-plugin-emr-6.7.0-aarch64.jar

6.6.0

3.2.0

Intel

xonai-spark-plugin-emr-6.6.0-x86_64.jar

Graviton

xonai-spark-plugin-emr-6.6.0-aarch64.jar

6.5.0

3.1.2

Intel

xonai-spark-plugin-emr-6.5.0-x86_64.jar

Graviton

xonai-spark-plugin-emr-6.5.0-aarch64.jar

3.1.2

Intel

xonai-spark-plugin-emr-6.4.0-x86_64.jar

Graviton

xonai-spark-plugin-emr-6.4.0-aarch64.jar

6.3.1

3.1.1

Intel

xonai-spark-plugin-emr-6.3.1-x86_64.jar

Graviton

xonai-spark-plugin-emr-6.3.1-aarch64.jar

6.3.0

Intel

xonai-spark-plugin-emr-6.3.0-x86_64.jar

Graviton

xonai-spark-plugin-emr-6.3.0-aarch64.jar

For more details of supported applications, please see the EMR 6.x release notes. For more information on Amazon EMR, please see the EMR product documentation.